progeCAD support, tips and troubleshooting forum. progeCAD works very similar to some versions of AutoCAD. Moderated.

Moderators: caddit, Moderators

#1943 by Steveboyy
Sun Feb 03, 2013 9:43 pm

I can't seem to turn off the green highlighting when inserting multiline text.

It comes up in the dialog box as I type it in and it is hard to read the black text with the dark green highlighting. I have tried everything to turn it off but I can't seem to manage it.

Right click - background and preferences.
I even changed the Options, Tools, Selection to a lighter colour, but no go.

What am I doing wrong. Thanks.


#1946 by caddit
Mon Feb 04, 2013 9:27 am
Hi Steveboyy,

It does sound like a mtext dialogue background colour issue - text is only highlighted when you select it.

What text colour are you using? If using BYLAYER or BYBLOCK, what is the colour assignment for the respective layer / block?

Does this occur with all drawings or just specific ones? Have you also tried mtext in a new drawing to check for same behaviour?

Just for clearer understanding, what colour IS being shown when you look at MTEXT -> Right Mouse Menu -> "Background Settings" and also "preferences"?

#1947 by Steveboyy
Mon Feb 04, 2013 9:53 am
I have tested other drawings and while not all, most have this green highlighting in MTEXT only, not single line text, and only in the dialogue box, not on screen after pressing enter.

Right clicking background colour always gives me Red. It won't accept a change to By layer or By Block. If I change to another colour, it will default back to Red later on - but there is not red to be seen - black text with a dark green highlight.

If I right click to Preferences, Background colour it has "default".
If I change this to say white, in the dialog box I get a black background with dark green highlighting and black text. Weird.

I am doing a fairy Text intensive drawing and it is very difficult to read entering text this way.

I would send you a screen shot but not sure how with the Img* thingy.


#1948 by Steveboyy
Mon Feb 04, 2013 8:33 pm
After some experimenting, I have discovered that setting the font width value to anything < 1 causes this dark green highlighting in the dialogue box.

Thing is I like the more condensed text, so using a value of 0.5 is my norm.

I still think it could be a bug because it is the same dark green as you get with on screen object selections. This I have already changed to a lighter colour under Options, but apparently it has no effect on the text dialogue box highlighting.

Could you please check it out and report it if it is a bug for a later fix in an update.


#1956 by Tyson
Fri Feb 08, 2013 4:38 am
I've observed this bug too. Though i can't explain it with the width factor though, i got when i simply changed the text style then in the properties box, and went and edited the text.

#1961 by caddit
Fri Feb 08, 2013 5:51 pm
The situation is difficult because it only affects isolated users. We can't reproduce it.

It may be graphics related. Have you tried upgrading your graphics card driver? This is an option that has resolved several odd reports..

#1964 by Steveboyy
Sun Feb 10, 2013 9:53 pm
Graphics drivers are up to date.

I did report it to Progecad as a ticketed problem.

Their response was : "It was forwarded to the Development Team, they will consider it for future software developments.
It has yet not been defined when it will be present, in a future progeCAD version".

2011 does not have this same issue, only the 2013 version.