progeCAD support, tips and troubleshooting forum. progeCAD works very similar to some versions of AutoCAD. Moderated.

Moderators: caddit, Moderators

#1735 by Bazza
Mon Feb 13, 2012 1:19 am
I created a drawing with all the symbols I use in MATV designs (Master Antenna Television). I then converted each symbol into blocks.

If I insert symbols (blocks) into a drawing and save, a message appears saying "invalid data". When I re-open this drawing all inserted blocks have disappeared.

Hoping someone can help. Thanks.

#1737 by caddit
Wed Feb 15, 2012 2:14 pm
Dear Bazza,

Can you please confirm:

1. Which version of progeCAD you are using on which operating system?

2. In what system did you originally create you symbols file? Run the audit command on the master symbols file you describe and report back the result. If many errors exist and aren't fixed after repeated runs of the audit command try exporting the file to an earlier version of DWG or copy/pasting the entire drawing content to a new file. Once audit reports no errors try to create and use the blocks from this new file.

3. Beyond that we may ask you to send us some of your "problem CAD blocks" and the drawing file that you are trying to INSERT them into.

#1739 by Bazza
Wed Feb 15, 2012 10:04 pm
Hi Caddit,

1. Windows 7

2. Created in above system. Running audit does report any errors.

When saving a drawing with an inserted block the following appears

"Your drawing contains invalid data. It has been saved, with that invalid data. Please see this log file for more information C:\Drawing\test_SaveErrors.log"

log file displays" 4118 Prj\lib\DRW\DWGdirectWriter.cpp 5 Invalid input"

Is this any help in solving my problem?