progeCAD support, tips and troubleshooting forum. progeCAD works very similar to some versions of AutoCAD. Moderated.

Moderators: caddit, Moderators

#1580 by dcwPE
Wed Aug 03, 2011 3:22 pm
I'm using progeCAD v. and in my paper space views I see a gray background with only the print area shown as black. There are also dashed lines around the perimeter of my print area. Anyone know how to turn these off? I would like for the entire paper space to show up as black without the dashed lines. Bother the "paper color" and "graphics screen color" are set to black in the options tab.

#1581 by caddit
Thu Aug 04, 2011 6:39 am
Hello dcwPE,

You can actually assign the mview frame itself to a layer (_vframe is a common name used for this sort of layer), and then freeze/turn off that layer from the toolbar.

The mview frames should then disappear and your should be able to print "borderless" viewports.

Does this address the problem or do we misunderstand?
#1582 by dcwPE
Fri Aug 05, 2011 3:04 am
actually I have my viewport set to a layer that does not print and therefore the "frame" of the viewport doesn't print (as expected). My specific issue is that everything outside of my print window (file>print>print window>drag area larger than viewport) shows up as a shade of gray while the print area shows up as black with two offset white dashed lines along the border. I assume this is some sort of visual check to see if the last plot actually plotted the area you wanted so that future plots can be checked at a glance. This shaded effect of the non-printed area in paperspace is what I want to turn off.
#1587 by caddit
Wed Aug 10, 2011 8:33 am
Hello dcwPE,

We discussed your question at length with the developers and they confirm that this is planned for 2012 version. For now what might serve you as a "work-around" on a drawing-by-drawing basis is to apply a custom oversize sheet size to the layout that is much larger than the region that you are actually printing to.

At that point you should have defined and applied a fictitious sheet size that extends far past the actual drawing region. At this point use "File -> Plot", and for "Print Area" defined in the "Scale/View" tab click "Window". Define just a portion of that oversized sheet to actually be printed, double check your scale and try Print Preview button at the bottom of the dialogue box.

It might take a couple of tries to get the combination right but it should work I think.
#1591 by dcwPE
Wed Aug 10, 2011 1:56 pm
I know this is a small issue of little or no relevance to progecad's usefullness or functionality, rather it deals more with my pickyness. Thanks for the input!