progeCAD support, tips and troubleshooting forum. progeCAD works very similar to some versions of AutoCAD. Moderated.

Moderators: caddit, Moderators

#1282 by caddit
Fri Oct 08, 2010 3:35 pm

We are posting this here for the benefit of several who have written us about a problem that has not actually been mentioned on the forum.

On certain system configurations, progeCAD 2010 Professional can crash occasionally when starting. Sometimes an error message is displayed in the crash, sometimes progeCAD simply seems to "disappear" while starting and needs to be started again.

This bug is linked to behaviour controlled by the system variable PRELOADPLOTSETTINGS.

The default value for this variable is "ON" (you can check it just by typing the word "PRELOADPLOTSETTINGS" into the progeCAD command line at the bottom and seing the value it returns). Simply setting PRELOADPLOTSETTINGS to OFF via the progeCAD 2010 command line, then stopping and re-starting progeCAD should in many cases relieve the problem. Meanwhile a proper fix to the problem is being developed.

As an additional note which is not specific to this problem, whenever progeCAD does crash for an unknown reason not yet discussed on our support pages, be sure to request a crash diagnostic tool from us so that we can look into the cause.

Also remember to check the Windows task manager for any stray processes still running called "icad.exe" in the event of an apparent crash and shut them down if you have to.
#1284 by caddit
Mon Oct 11, 2010 7:23 am
Hi Hunarch,

As stated before, the bug here discussed usually happens occasionally - i.e. not all of the time. Specifically for those users who report something like "After reboot I try to start progeCAD but it freezes, crashes or dissappears - but the next time it starts without problem. What's going on?".

The PRELOADPLOTSETTINGS system variable in progeCAD can therefore be changed at that time when progeCAD has not crashed on startup. We have had good results with this on the Sydney lab systems.

If you try to start progeCAD ten times after reboot, and all ten times progeCAD crashes then there is probably something else wrong and you might need to re-install before further troubleshooting is possible.

We reinforce that this is only a temporary work-around solution and something more permanent is forthcoming as a patch.

#1292 by beej67
Thu Oct 14, 2010 8:47 pm
I get an error quite regularly where it freezes on startup. Soon after the smaller graphical ProgeCad box appears, the main ProgeCad screen goes blank, and they stay blank and load no further. If I shut it down manually with the task manager it usually boots fine, but not always.

Is this the same error you're talking about?


#1293 by Hunarch
Sat Oct 16, 2010 9:21 pm
I have ProgeCad an my desktop pc and my tablet pc.

On the desktop pc, ProgeCad would stall during opening at various stages. On the first attempt it would get no further than the splash screen but nothing else; at other times it would fully open but not respond. The work-around suggested by Caddit appears to have fixed this problem (although it was not the problem that was being addressed by Caddit, but thank you Caddit anyway!)

On my tablet pc, ProgeCad suddenly disappears just before it seems to have fully loaded (but with the splash screen still present).

I have had ProgeCad working properly on my tablet pc several months ago, but at some stage since then this problem has occurred.

I have loaded ProgeCad more than 10 times with the same result. I have also uninstalled and reinstalled it a few times, but without any better outcome.

Do you, Caddit or others, have any further suggestions?
#1297 by caddit
Mon Oct 18, 2010 2:29 pm
Hello all,

We have been working on an an important update for this software. We have just uploaded progeCAD on so please make sure that you software is updated as this bug has been addressed in this release.
#1299 by Hunarch
Tue Oct 19, 2010 12:15 am
I have installed the update: the one on my desktop is working, but the one on my tabletop is manifesting the same symptoms as before: it loads up to the point when the splash screen normally fades and disappears, except everything disappears and closes (it crashes). There is a message at the very top left hand side of the screen (where the opened file name appears) stating that the program is not responding.

Do you have other suggestions?
#1303 by caddit
Thu Oct 21, 2010 3:20 am
Hi Hunarch,

What operating system are you running on the tablet PC? Is it using an Intel Atom or Celeron processor (These are not recommended for running any kind of serious CAD application)? How much RAM does it have?

What kind of network and printer configuration are you running on the tablet PC?
#1306 by Hunarch
Thu Oct 21, 2010 4:40 am
Motion Computing J3400 tablet pc. Windows 7 32 bit. Intel Core 2 Duo CPU, U 9600@1.6 Gz; 4 Gb Ram. No printer configuration. Standard Home network set-up.

Thanks for response.

#1308 by caddit
Thu Oct 21, 2010 5:24 am
Hi Hunarch,

Does this crash occur when opening an existing drawing or also during "cold start" from the Window Start Menu?

Do you have the xcrash diagnostic tool installed?

Please confirm that your full progeCAD version is
#1309 by Hunarch
Thu Oct 21, 2010 5:35 am
I have installed Cold start from Win Start Menu; I don't have existing drawings to open. I have "Rescue" but l don't think that is the x crash diagnostic tool, or is it?

#1349 by intheusa
Tue Nov 16, 2010 10:10 pm
WIN PRO XP2 CORE2DUO 2G-mem ProgeCad

Happens on my desktop also but I work around it with Cntrl-Alt-Delete and shut down in task manager. Sometime occurs again on 2nd program start but never occured 3 times in a row.

My question is, how about a more informative system variable help file. I looked up PRELOADPLOTSETTINGS and its not there, but comes back as a variable in the command line.

So what other good undocumented comands and system variables are there ?

#1355 by Hunarch
Wed Nov 17, 2010 12:05 pm

Do you have a reply to my last post? l am still without use of progecad on my tablet.

#1388 by Hunarch
Mon Dec 06, 2010 7:41 pm
Further to my last post, Skype started crashing whenever it loaded, and Internet Explorer would no longer load. I concluded that there was system corruption and so I reformatted my hand disk and reinstalled everything. Everything is now working.