progeCAD support, tips and troubleshooting forum. progeCAD works very similar to some versions of AutoCAD. Moderated.

Moderators: caddit, Moderators

#995 by deang
Tue Mar 30, 2010 4:22 am
The dialog box doesn't open anymore. I see the command line, a "1" shows up in the command dialog but no pop up box to enter the file info. I've tried reinstalling the software but no luck.

ProgeCAD 2009 pdf to dxf converter still works like usual. I even tried restoring the computer to a week earlier.

Win 7 32 bit
lots of ram
lots of memory
everything updated
#998 by caddit
Tue Mar 30, 2010 6:17 pm
Hello deang,

So far we haven't been able to reproduce this behaviour. It's possible that having both progeCAD 2009 and 2010 running on the same system could be a cause - as this often also causes a known possible conflict between the progeCAD 2009 PDF printer and that of 2010. I am forwarding this case to the knowledge base and see if there are similar cases.
#999 by deang
Thu Apr 01, 2010 1:04 am
It started working again today. I don't know why. It sounds like there is a conflict with another program. I'll try and figure out what it is.

#1050 by ellie
Tue May 11, 2010 9:35 am
i am having the same problem , but i have deleted progecad2009 ( all except the .exe file - just in case i need it again?)
when i try to convert pdf to dxf a dialog box tells me i have "to run visual basic , you will have to install VBA6 .See readme for more details "
i can find no reference to anything related to VBA6 in the readme file .
i have tried the command vbaload , which asks for .vbi files . i have tried to load all the .vbi files contained in progecad2010 but nothing has happened . i have a vba6 folder in programfiles/commonfiles/microsoftshared but there are no .vbi files in that . i used to be able to run the pdf to dxf converter in 2009 . do you have any suggestions ?
#1054 by caddit
Thu May 13, 2010 2:39 pm
Hello ellie,

This isn't so much a PDF problem as a VBA problem. Sometimes the VBA runtime gets corrupted through un-installs and re-installs of progeCAD.

Normally its easy enough to fix. Log in as administrator to do it.

As local administrator, open Windows Explorer (the file browser - not the web browser :) ) and navigate to C:\Program Files\progeSOFT\progeCAD 2010 Professional ENG\VBA and double-click on VBAOF11.MSI

Then reboot to be safe (though not usually needed)

Let us know if that fixes it. BTW we are still looking into your other problem - it seems that some systems don't duplicate the problem. We're working on it.

#1055 by ellie
Fri May 14, 2010 3:23 am
hi , thanks for the reply - unfortunately that didn't fix the issue .
#1056 by caddit
Fri May 14, 2010 3:59 am
Hello ellie,

You can try to re-install the CAD PDF printer itself now - again logged in as the local system administrator.

Using Windows Explorer, browse to:
C:\Program Files\progeSOFT\progeCAD 2010 Professional ENG\PDFADD

Double-click on "install.exe"

Follow any prompts and accept any defaults (if asked). You may need to reboot . Then try the PDF printer again.

#1248 by Al
Thu Sep 16, 2010 8:09 am
#1250 by caddit
Fri Sep 17, 2010 5:55 am
Hello Al,

Recently one of our users was able to fix this by restoring progeCAD default settings as described here:

Afterward if PDF2DXF is still not working you can try to reinstall VBA then reinstall PDF2DXF from those two subfolders.

If all that does not work then try this:
Stop progeCAD
Windows START menu -> . . -> progeCAD 2010 Pro Eng -> Utility -> "User Support Folder"
This will open an explorer window to your local support files. Navigate up two folder levels where you see just the "R10" folder displayed. Rename it to R10.old and restart progeCAD.

All else failing, try a fresh re-install (uninstall completely, make sure "C:\Program Files\progeSOFT\progeCAD 2010 Professional ENG" is deleted and re-install as full system administrator using: ... CADDIT.exe

You should not have to re-activate the software with your serial code.

#1251 by Al
Fri Sep 17, 2010 7:04 am
Excellent thanks guys!!

The one which worked for me was renaming the "R10" folder to "R10.old" and then restarting ProgeCAD.